Skip to main content

Cara Meremote Mikrotik Ip Dynamis

Jasa setting mikrotik - Cara Remote router mikrotik menggunakan ip dynamis bisa saja sangat memusingkan, apalagi kita sebagai owner warnet yang menggunakan koneksi internet speedy paket family.



Tentu memusingkan jika terjadi masalah jika kita tidak dapat meremotenya karena kita kehilangan ipaddresnya setiap kali modem mati, atau restart, atau terputus koneksinya dari internet.
Mungkin bukan zaman lagi pake paket family untukwarnet, tapi begitulah kadang kadang kondisi memaksa kita harus menggunakan koneksi itu.Ada beberapa cara untuk mengatasi masalah itu, agar kita bisa meremote mikrotik nun jauh disana dengan ip yang berubah ubah itu (dinamis). Caranya meremote mikrotik ip dynamis banyak caranya, setidaknya sejauh pengembaraan saya ada 3 yang masih dapat di gunakan, seharusnya ada 4 tapi salah satu penyedia domain tidak lagi memberikan subdomain free untuk free account. Artinya anda harus membayar service mereka.

Cara Pertama Untuk Pengguna CHANGEIP.COM

/system script

add name=HomingBeacon-Simple policy=\
ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
date / Simple Edition\r\
\n# Written by Sam Norris, ChangeIP.com\r\
\n# Copyright ChangeIP.com 2009\r\
\n# For support send mail to [email protected]\r\
\n#\r\
\n# 2009-06-22 RouterOS 3.25 Tested\r\
\n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
\n#\r\
\n# OVERVIEW: %\r\
\n# This script will update a ChangeIP.com dynamic dns hostname\r\
\n# with an ip address located directly on an interface.\r\
\n# %\r\
\n# NOTES: %\r\
\n# IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
\n# AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
\n# have created this script and tested that it works by running it\r\
\n# manually you can schedule it to run every few minutes.\r\
\n# %\r\
\n# CONFIGURATION FIELD DEFINITIONS:\r\
\n# ddnsuser: Enter your ChangeIP.com user id.\r\
\n# ddnspass: Enter your ChangeIP.com password.\r\
\n# ddnshost: Enter the hostname (www.example.com) to update.\r\
\n# ddnsinterface: Enter a list of interface names - case sensative.\r\
\n# %\r\
\n# %\r\
\n# %\r\
\n# %\r\
\n# % % %\r\
\n# % % %\r\
\n# % % %\r\
\n# %\r\
\n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
\n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
\n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
\n:global ddnsuser \"YourChangeIPUserID\"\r\
\n:global ddnspass \"PASSWORD\"\r\
\n:global ddnshost \"MyRouterHostname.example.org\"\r\
\n:global ddnsinterface \"ether1\"\r\
\n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
\n# END OF USER DEFINED CONFIGURATION\r\
\n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
\n\r\
\n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
\_name=system] version] )\r\
\n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
face] address ]\r\
\n:global ddnslastip\r\
\n\r\
\n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
\"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
}\r\
\n\r\
\n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
0.0.0/0 }\r\
\n\r\
\n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
\n\r\
\n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
lease check.\")\r\
\n\r\
\n} else={\r\
\n\r\
\n :if (\$ddnsip != \$ddnslastip) do={\r\
\n\r\
\n :log info \"DDNS: Sending UPDATE!\"\r\
\n :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
\n :global ddnslastip \$ddnsip\r\
\n\r\
\n } else={ \r\
\n\r\
\n :log info \"DDNS: No changes necessary.\"\r\
\n\r\
\n }\r\
\n\r\
\n}"

Paste script tersebut di terminal mikrotik, dan jangan lupa mengubah script tersebut, yaitu pada bagian:

\n:global ddnsuser \"YourChangeIPUserID\"\r\
\n:global ddnspass \"PASSWORD\"\r\
\n:global ddnshost \"MyRouterHostname.example.org\"\r\
\n:global ddnsinterface \"ether1\"\r\

Saya anggap saja anda sudah faham untuk mengganti baris tersebut dengan apa. Jika tidak mengerti contact saya di commentar. Jika scripts diatas tidak ada errornya lakukan langkah terakhir di bawah ini, paste di terminal juga.

/system scheduler
add comment="" disabled=no interval=5m name=DDNS on-event=HomingBeacon-Simple policy=read,write,policy,test,password start-time=startup

Remote ip Mikrotik Ip Dynamis (ip yang berubah ubah ) menggunakan AFFRAID.ORG 

Buka Notepad dan paste code dibawah ini, ke notepad tersebut
 
# Update DNS on Freedns.afraid.org
:global host "freedns.afraid.org"
:global url "urlddns"

/tool fetch url=$url host=$host

Kenapa harus kenotepad, karena pada baris itu ada yang harus kita ubah. yaitu baris urlddns.

Caranya : Buka account afraid anda Klik Dynamic DNS, dan scroll kebawah lihat domain yang ingin anda revers ke ip mikrotik kita yang dynamis. Jika anda belum memiliki domain yang di masukkan di afraid, buatlah sebuah subdomain, dengan mengklik tulisan REGISTRY dan buat subdomain di salah satu domain yang anda sukai di list domain yang disediakan oleh afraid.org jika sudah kembali lagi ke Dynamic DNS, scroll kebawah dan lihat tulisan Direct URL, klik kanan Copy Link nya, dan timpa tulisan urlddns pada scripts diatas. Jadinya scripts diatas seperti berikut ini.

# Update DNS on Freedns.afraid.org
:global host "freedns.afraid.org"
:global url "http://freedns.afraid.org/dynamic/update.php?VEdmU24wTVRTTUlBQUs5NELAELADAEdae33"

/tool fetch url=$url host=$host
  • Klik System -> Scripts -> klik tanda add [+] yang berwarna merah
  • Name dengan afraid 
  • Policy centang semua 
  • Paste code yang  kita edit tadi di bagian source kotak scripts
  • Apply -> Ok
Terakhir
  • Klik System -> Scheduler -> klik add [+]
  • Isikan afraid pada name dan On Event.
  • Centang semua policy 
  • Pada Start time pilih startup 
  • Interval isikan 00:10:00 
  • Klik tombol Ok.
Hanya itu yah...!! hanya itu. Selamat mencoba..!!

Untuk Trik Satunya saya tuliskan pada kesempatan lain ya..!!

sumber: FMI

Comments

Popular posts from this blog

Pengertian Masquerade Mikrotik

Pengertian Masquerade Mikrotik - Jasa setting mikrotik - Fungsi Masquerade pada mikrotik - Masquerade mungkin bisa di artikan sebagai topeng untuk bisa terkenoneksi ke jaringan internet menggunakan ip private, atau simplenya masquerade mikrotik atau masquerade linux merupakan sebuah metode yang mengizinkan dan memperbolehkan ip private untuk terkoneksi ke internet dengan mengunakan bantuan sebuah ip public /bertopengkan sebuah ip publik. Dengan bantuan masquerade sebuah ip publik dapat mendistribusikan koneksi internet ke banyak ip private. Ip private merupakan ip address yang tidak masuk kedalam routing table router jaringan internet global. Dan ip private hanya bisa di gunakan didalam jaringan lokal. Karena ip private ini hanya bisa di gunakan dalam jaringan LAN atau local area network, maka lahirlah masquerade yang menjadi topeng agar ip private (LAN) dapat berinteraksi ke internet. Berikut ini range ip private yang sering di gunakan dijaringan lokal: 10.0.0.0 - 10.255.255.255 172.

SIUP TDP Lama Tak Perlu Diperpanjang

Permendag Baru Terbit, SIUP Tak Perlu Diperpanjang Pelaku usaha yang telah memiliki SIUP tidak perlu lagi melakukan pendaftaran ulang karena SIUP berlaku selama perusahaan perdagangan menjalankan kegiatan usaha di bidang perdagangan.   Menteri Perdagangan Enggartiasto Lukita menyatakan telah mengeluarkan Peraturan Menteri Perdagangan (Permendag) terbaru yang mengatur penghapusan kewajiban pendaftaran ulang Surat Izin Usaha Perdagangan (SIUP), serta Penyederhanaan prosedur dan penghapusan kewajiban biaya administrasi pembaruan Tanda Daftar Perusahaan (TDP). Kedua Permendag baru ini memberi jaminan kemudahan berusaha bagi pelaku usaha di bidang perdagangan. Mendag menegaskan kewajiban pendaftaran ulang Surat Izin Usaha Perdagangan (SIUP) setiap lima tahun dihapus.  "Pemerintah Ingin meningkatkan pelayanan dan kemudahan berusaha kepada seluruh pelaku usaha di bidang perdagangan," tegas Mendag Enggar dalam rilis, Kamis (23/2). (Baca Juga: Bekraf Janji Bantu Pembuatan Badan Hukum

Error 404: Not Found User Manager Mikrotik

Jasa setting hotspot mikrotik - Jika anda sedang di pusingkan ERROR 404: Not Found saat membuka user manager hotspot anda dari browser, kesalahan itu hanya sedikit saja. Anda hanya perlu merubah port http pada  IP->SERVICE ke salah satu port kosong yang anda miliki, secara default port http mikrotik adalah 80, nah anda bisa menggantinya dengan port lain, misalnya port 81, 8080, atau port berapa saja yang terbuka.